graphp/plaintext

Proprietary plaintext graph format

v0.1.1 2015-03-08 10:16 UTC

This package is auto-updated.

Last update: 2021-10-22 19:24:22 UTC


README

Proprietary plaintext graph format

Note: This project is in beta stage! Feel free to report any issues you encounter.

Install

The recommended way to install this library is through composer. New to composer?

{
    "require": {
        "graphp/plaintext": "~0.1.0"
    }
}

This project aims to run on any platform and thus does not require any PHP extensions and supports running on legacy PHP 5.3 through current PHP 7+ and HHVM. It's highly recommended to use PHP 7+ for this project.

Tests

To run the test suite, you first need to clone this repo and then install all dependencies through Composer:

$ composer install

To run the test suite, go to the project root and run:

$ php vendor/bin/phpunit

License

Released under the terms of the permissive MIT license.