google/civic-client

This package is not installable via Composer 1.x, please make sure you upgrade to Composer 2+. Read more about our Composer 1.x deprecation policy.
There is no license information available for the latest version (dev-master) of this package.

Google Civic API Client

dev-master 2013-07-10 18:40 UTC

This package is not auto-updated.

Last update: 2021-06-07 11:41:14 UTC


README

This is a minimalistic API client for Google Civic API

Installation

Installation is conveniently provided via Composer.

To get started, install composer in your project:

$ curl -s https://getcomposer.org/installer | php

Next, add a composer.json file containing the following:

}
    "require": {
        "google/civic-client": "dev-master"
    }
}

Finally, install!

$ php composer.phar install

Usage

Using the Google Civic client is easy:

<?php

require_once '../src/Client.php';

try {
    $client = new GoolgeCivic('YOUR API KEY');
    $result = $client->getElections();
} catch (Exception $e) {
    echo $e->getMessage();
}
print_r($result);