gonzaloalonsod/afip-bundle

Web Services de AFIP

Installs: 41

Dependents: 0

Suggesters: 0

Security: 0

Stars: 5

Watchers: 2

Forks: 4

Open Issues: 0

Type:symfony-bundle

v1.2 2021-03-10 20:55 UTC

This package is auto-updated.

Last update: 2022-06-10 23:52:32 UTC


README

Web Services de AFIP

Installation

Applications that don't use Symfony Flex

Step 1: Add file config

In the config/packages/afip_parameters.yaml file of your project:

afip:
    parameters:
        CUIT: 20111111112
        production: false
        res_folder: 'src/afip_res/'
        ta_folder: 'src/afip_res/'
        cert: 'cert'
        key: 'key'
        passphrase: ''

Step 2: Download the Bundle

Open a command console, enter your project directory and execute the following command to download the latest stable version of this bundle:

$ composer require gonzaloalonsod/afip-bundle

This command requires you to have Composer installed globally, as explained in the installation chapter of the Composer documentation.

Step 3: Enable the Bundle

Then, enable the bundle by adding it to the list of registered bundles in the config/bundles.php file of your project:

<?php

return [
    // ...
    Gonzaloalonsod\AfipBundle\AfipBundle::class => ['all' => true],
];

Step 4: Create res_folder

Add files cert and key

Example use Afip in Controller

<?php

namespace App\Controller;

use Symfony\Bundle\FrameworkBundle\Controller\AbstractController;
use Symfony\Component\Routing\Annotation\Route;

use Gonzaloalonsod\AfipBundle\Controller\AfipController;

class AppController extends AbstractController
{
    /**
     * @Route("/app", name="app")
     */
    public function index(AfipController $afip)
    {
        dump($afip->getWS());

        return $this->render('app/index.html.twig', [
            'controller_name' => 'AppController',
        ]);
    }
}

Other Example use Afip dependency injection

...
use Gonzaloalonsod\AfipBundle\Controller\AfipController;
...
    public function index()
    {
        $afip = $this->container->get(AfipController::class);
    }
...

Applications that use Symfony Flex (Developing)

Open a command console, enter your project directory and execute:

$ composer require gonzaloalonsod/afip-bundle

Dependencias

Author

Gonzalo Alonso - gonzaloalonsod@gmail.com