geogkary/webmart

This package is not installable via Composer 1.x, please make sure you upgrade to Composer 2+. Read more about our Composer 1.x deprecation policy.

A basic PHP framework for web applications and websites.

v2.0.5 2020-04-24 13:40 UTC

This package is auto-updated.

Last update: 2021-05-24 16:35:49 UTC


README

A basic PHP framework for web applications and websites. http://webmartphp.com/

Required

  • PHP: >=5.6.*
  • Flight, by mikecao
  • Apache

Suggested

Released under the MIT License.

How to Install

See available versions on Packagist or GitHub.

A. Manual

  • Download Webmart and unzip in your directory.
  • Download Flight and unzip inside webmart/engine/ (make sure it's a subfolder named flight).
  • Setup your theme folders inside webmart/themes/ - feel free to use the Boilerplate theme.
  • Open in your browser.

B. Composer

Navigate to your directory and run:

composer require webmart/webmart

Create an index.php and require the autoloader:

require 'vendor/autoload.php';

Setup your theme folders inside themes/ (same level as vendor/) - feel free to use the Boilerplate theme.

Open in your browser.

How to Configure

See the docs for more.