esoftslimited/yii2-blog

This package is not installable via Composer 1.x, please make sure you upgrade to Composer 2+. Read more about our Composer 1.x deprecation policy.

Yii2 blog module forked from pendalf89 for improvement and learning purpose

dev-master 2015-08-29 15:45 UTC

This package is not auto-updated.

Last update: 2021-11-27 03:22:58 UTC


README

Yii2 blog module Installation

The preferred way to install this extension is through composer.

Either run

php composer.phar require --prefer-dist pendalf89/yii2-blog "*"

or add

"pendalf89/yii2-blog": "*"

to the require section of your composer.json file.

Apply migration

yii migrate --migrationPath=vendor/pendalf89/yii2-blog/migrations

Configuration:

'modules' => [
    'blog' => [
        'class' => 'pendalf89\blog\Module',
        // This option automatically translit entered titles 
        // from russian symbols to english on fly. Default false.
        'autoTranslit' => true, 
        // Some options for CKEditor. Default custom options.
        'editorOptions' => [],
        // callback function for create post view url. Have $model argument.
        'viewPostUrlCallback' => function($model) {
                return '/' . $model->id;
            },
    ],
],

Don't forget configure PendalF89/yii2-filemanager extension.