errors/exceptions

An error handler that produces error exceptions when a native error occurs.

0.2.0 2017-07-03 23:04 UTC

README

Adding this package as a dependency indicates that the root package is designed to work with exception-based error handling as described in the specification, and will not work correctly with the native errors that PHP produces by default:

composer require errors/exceptions

This package installs an exception-based error handler upon installation. It is not necessary to manually install the error handler via set_error_handler().

Providing an alternate error handler

To use an alternate error handler, simply install the alternate handler and use Composer's provide option:

{
    "provide": {
        "errors/exceptions": "0.1.0"
    }
}

The "provided" error handler should still implement the specification.

Reporting deprecations

In some cases, such as CI builds, it is desirable to report on deprecations. To enable this behavior, set the environment variable PHP_ERROR_EXCEPTION_DEPRECATIONS=1.

Bypassing the error handler

For testing purposes only, it is possible to bypass the error handler by setting the environment variable PHP_ERROR_EXCEPTIONS=0.