ericliao79/laravel5-allpay

This package is not installable via Composer 1.x, please make sure you upgrade to Composer 2+. Read more about our Composer 1.x deprecation policy.

Laravel5 allpay package.

v0.0.4 2017-09-24 08:40 UTC

This package is auto-updated.

Last update: 2021-05-29 00:53:22 UTC


README

Latest Stable Version Build Status CircleCI Coverage Status License

Taiwan's Third-Party Payment SDK all-in-one for Laravel.

This package is not stable.

Requirements

  • PHP 7.1 or later
  • Laravel: 5.5 or later

examlp

l5-allpay-example

Installation

add to composer.json

"ericliao79/laravel5-allpay": "^0.0.1"

or

composer require ericliao79/laravel5-allpay

In config/app.php add providers

ericliao79\l5allpay\Providers\l5allpayServiceProvider::class

In .env add, you can register on

ALLPAY_DEBUG_MODE=false
ALLPAY_STORE_ID=xxxxx
ALLPAY_HASH_KEY=xxxxxxxxx
ALLPAY_HASH_IV=xxxxxxxxxxxx

### default return url
ALLPAY_ReturnUrl=/return
ALLPAY_NotifyURL=/callback

And publish config

php artisan vendor:publish

ToDo

  • Opay
  • pay2go