dorsetdigital/silverstripe-http2

Adds support for HTTP2 features

Installs: 5 232

Dependents: 0

Suggesters: 0

Security: 0

Stars: 6

Watchers: 4

Forks: 1

Open Issues: 1

Type:silverstripe-vendormodule

v1.0.1 2020-12-15 16:48 UTC

This package is auto-updated.

Last update: 2024-05-14 16:49:54 UTC


README

Please note: The functionality this module provides is now available in a different module that also provides additional functionality: https://github.com/DorsetDigital/silverstripe-enhanced-requirements

This module will remain, but will not be actively developed beyond critical bugfixes. Please use the enhanced requirements module from now on

Adds basic HTTP2 functionality like requirements push

This module adds the necessary HTTP headers to SilverStripe to enable HTTP/2 push functionality on servers which support it. By default, the module will send the header containing all the CSS and JS files which have been added to a site using the Requirements API.

Requirements

*Silverstripe 4.x

Installation

Install with composer require dorsetdigital/silverstripe-http2

Usage

Add a config YML file to enable:


---
Name: httptest
---
DorsetDigital\HTTP2\DDMiddleware:
  enabled: true