There is no license information available for the latest version (1.0) of this package.

Doctrine entity generator module

1.0 2014-03-12 18:00 UTC


Doctrine entity generator module for Zend Framework 2.

Adding module
php composer.phar require bitweb/doctrine-entity-generator-module
# (When asked for a version, type `1.*`)

or add following to composer.json

"require": {
  "bitweb/doctrine-entity-generator-module": "1.*",

Loading module in APP_ROOT/config/application.config.php:

   'modules' => array(

This module requires adding initializer into module.config.php for ServiceManager:

    'service_manager' => array(
        'initializers' => array (
            function ($service, $sm) {
                if ($service instanceof ObjectManagerAwareInterface) {

This is needed for the module to use project's Object manager.

Now, web interface can be accessed for generating entities.