artisanry/swagger

This package is abandoned and no longer maintained. No replacement package was suggested.

Swagger UI Integration for Laravel

Installs: 6

Dependents: 0

Suggesters: 0

Security: 0

Stars: 0

Watchers: 1

Forks: 0

Open Issues: 1

Language:JavaScript

3.2.0 2019-08-28 13:06 UTC

This package is auto-updated.

Last update: 2020-01-28 14:09:40 UTC


README

Build Status PHP from Packagist Latest Version License

Fork of L5-Swagger with support for Definitions based on Eloquent Models & kept up-to-date with the newest Swagger UI release.

Installation

Require this package, with Composer, in the root directory of your project.

$ composer require artisanry/swagger

To get started, you'll need to publish the vendor assets:

php artisan vendor:publish --provider="Artisanry\Swagger\SwaggerServiceProvider"

Testing

$ phpunit

Security

If you discover a security vulnerability within this package, please send an e-mail to hello@basecode.sh. All security vulnerabilities will be promptly addressed.

Credits

This project exists thanks to all the people who contribute.

License

Mozilla Public License Version 2.0 (MPL-2.0).