aporat/application_controller_plugin_forcessl

Zend Framework 1 controller plugin that force all http requests to be under SSL

1.0.0 2013-05-16 20:03 UTC

README

Build Status Coverage Status

Requirements

  • PHP >= 5.3
  • Zend Framework >= 1.11

Getting Started

The easiest way to work with this package is when it's installed as a Composer package inside your project. Composer isn't strictly required, but makes life a lot easier.

If you're not familiar with Composer, please see http://getcomposer.org/.

  1. Add the package to your application's composer.json.

    {
        ...
        "require": {
            "aporat/application_controller_plugin_forcessl": "dev-master"
        },
        ...
    }
    
  2. Run php composer install.

  3. If you haven't already, add the Composer autoload to your project's initialization file. (example)

    require 'vendor/autoload.php';
    

Quick Example

Add this line anywhere in your bootstrap:

Zend_Controller_Front::getInstance()->registerPlugin(new Application_Plugin_ForceSSL());