acquia/blt-drupal-check

Drupal Check integration for Acquia BLT

dev-master 2021-01-27 18:03 UTC

This package is not auto-updated.

Last update: 2021-09-22 20:59:17 UTC


README

This is an Acquia BLT plugin providing integration with Drupal Check.

This plugin provides a set of commands in the tests namespace that use Drupal Check to check for coding standard violations.

This plugin is community-supported. Acquia does not provide any direct support for this software or provide any warranty as to its stability.

Installation and usage

To use this plugin, you must already have a Drupal project using BLT 12 or higher.

In your project, require the plugin with Composer:

composer require --dev acquia/blt-drupal-check

License

Copyright (C) 2020 Acquia, Inc.

This program is free software: you can redistribute it and/or modify it under the terms of the GNU General Public License version 2 as published by the Free Software Foundation.

This program is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License for more details.