faustbrian/affilinet-php

This package is abandoned and no longer maintained. The author suggests using the plients/affilinet package instead.

A developer-experience focused Affilinet API client.

dev-master / 1.0.x-dev 2019-06-04 04:21 UTC

This package is auto-updated.

Last update: 2019-06-04 05:33:22 UTC


README

Build Status PHP from Packagist Latest Version License

Installation

Require this package, with Composer, in the root directory of your project.

$ composer require plients/affilinet-php

Usage

$client = new Plients\Affilinet\Client($username, $password);

$response = $client->service('product')->getShopList($parameters);

if($response->hasErrors()) {
    dd($response->errors());
} else {
    dd($response->body());
}

Testing

$ phpunit

Security

If you discover a security vulnerability within this package, please send an e-mail to hello@basecode.sh. All security vulnerabilities will be promptly addressed.

Credits

License

MIT © Brian Faust