bartlett/php-compatinfo

Find out the minimum version and the extensions required for a piece of code to run

5.0.11 2017-12-12 12:46 UTC

README

PHP CompatInfo is a library that can find the minimum version and the extensions required for a piece of code to run.

It is distributed as source code (install via composer) and a PHAR version that bundles all dependencies in a single file.

Follow development on the official Blog.

Have a look on branch 4.5 for previous stable API 4.x

Caution Branch 4.5 will not accept any more any feature requests.
Caution Branch 5.0 will not accept any more any feature requests.

Requirements

PHP 5.5.0 or above.

Install

You can either :

  • download the phar version 5.0.11

  • install via packagist the current source dev-master

Documentation

The documentation for PHP CompatInfo 5.0 in English is available online or downloadable offline to read it later (multiple formats available).

AsciiDoc source code is available on docs folder of the repository.

Contribute

Contributions to source code and its documentation are always welcome.

Authors

  • Laurent Laville (current lead developer)

  • Thanks to Davey Shafik. He introduced his proposal in 2004, that gave birth of a PEAR package named PHP_CompatInfo.

  • Thanks also to Remi Collet, a contributor of first hours.

License

This handler is licensed under the BSD-3-clauses License - see the LICENSE file for details